hdu1385Minimum Transport Cost(floyd 打印字典序最小路径)

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13121    Accepted Submission(s): 3716


 

Problem Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

 

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

 

Output

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

扫描二维码关注公众号,回复: 4313068 查看本文章

 

Sample Input

 

5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0

 

Sample Output

 

From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17

 

Source

Asia 1996, Shanghai (Mainland China)

 

Recommend

Eddy

 注意钱分两部分,除了路的那部分还有经过的点在注意一下输出个格式

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define maxn 150
int n;
int cost[maxn];
int dis[maxn][maxn];
int path[maxn][maxn];
void floyd()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
        path[i][j]=j;
        }
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(dis[i][k]<inf&&dis[k][j]<inf)
            {if(dis[i][k]+dis[k][j]+cost[k]<dis[i][j])
            {dis[i][j]=dis[i][k]+dis[k][j]+cost[k];
            path[i][j]=path[i][k];}
            else if(dis[i][k]+dis[k][j]+cost[k]==dis[i][j]&&path[i][j]>path[i][k])
            {
                path[i][j]=path[i][k];
            }
            }
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            scanf("%d",&dis[i][j]);
            if(dis[i][j]==-1)
                dis[i][j]=inf;
        }
        for(int i=1;i<=n;i++)
        scanf("%d",&cost[i]);
        int c,d;
        floyd();
        while(true)
        {scanf("%d%d",&c,&d);
            if(c==-1&&d==-1)
                break;
            printf("From %d to %d :\n",c,d);

            if(c!=d)
            {
                printf("Path: %d",c);
                int u=path[c][d];
             while(true)
             {
                printf("-->%d",u);
                 if(u==d)
                 {printf("\n");
                 break;
             }
             u=path[u][d];

            }
            }
            else
               printf("Path: %d\n",c);
            printf("Total cost : %d\n\n",dis[c][d]);


        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84670726