hdu 4280 Island Transport

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4280

 In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.

Input

  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.

Output

  For each test case, output an integer in one line, the transport capacity.

Sample Input

 

2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4

Sample Output

 

9 6

在n个岛屿中,有m条双向航线,航线有单位时间内的运输上限,现在求从最左侧到最右侧的最大运输量

一道简单的网络流,卡时间题

#include<stdio.h>
#include <algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 1e5 + 10;
const int inf = 0x3f3f3f3f;
int cas = 1, T;
int d[maxn], cur[maxn], start, tend;
struct node
{
	int to, cap, next;
}edge[maxn << 1];
//vector<node>mp[maxn];
int head[maxn];
bool vis[maxn];
int cnt;
void addedge(int start, int to, int cap)
{
	edge[cnt].to = to;
	edge[cnt].cap = cap;
	edge[cnt].next = head[start];
	head[start] = cnt++;
}
bool bfs()
{
	memset(d, -1, sizeof(d));
	queue<int>pq;
	pq.push(start);
	d[start] = 0;
	while (!pq.empty())
	{
		int x = pq.front();
		pq.pop();
		if (x == tend)return true;
		for (int i = head[x]; i != -1; i = edge[i].next)
		{
			int temp = edge[i].to;
			if (d[temp] == -1 && edge[i].cap>0)//没有标记,且可行流大于0
			{
				d[temp] = d[x] + 1;
				pq.push(temp);
			}
		}
	}
	return false;//汇点是否成功标号,也就是说是否找到增广路
}
int dfs(int x, int cap)
{
	if (x == tend)return cap;
	int flow = 0, f;
	for (int i = head[x]; i != -1; i = edge[i].next)
	{
		int temp = edge[i].to;
		if (d[temp] == d[x] + 1 && edge[i].cap)
		{
			f = dfs(temp, min(cap - flow, edge[i].cap));
			if (f > 0)
			{
				edge[i].cap -= f;
				edge[i ^ 1].cap += f;
				flow += f;
				if (flow == cap)break;
			}
		}
	}
	if (!flow) d[x] = -1;//防止重搜
	return flow;
}
int maxflow()
{
	int flow = 0, f;
	while (bfs())
	{
		while ((f = dfs(start, inf))>0)
			flow += f;
	}
	return flow;
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	int n, m;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &n, &m);
		cnt = 0;
		memset(head, -1, sizeof(head));
		int x, y, u, v, w;
		int tmax = -inf, tmin = inf;
		start = tend = 1;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &x, &y);
			if (x <= tmin)start = i, tmin = x;
			if (x >= tmax)tend = i, tmax = x;
		}
		while (m--)
		{
			scanf("%d%d%d", &u, &v, &w);
			addedge(u, v, w);
			addedge(v, u, w);
		}
		int ans = maxflow();
		printf("%d\n", ans);
	}
}

猜你喜欢

转载自blog.csdn.net/Evildoer_llc/article/details/83247590