HDU 1385 Minimum Transport Cost(Floyd + 路径输出)

Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
 
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
 
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17


题意:

有N个城市,给出一个N*N邻接矩阵,-1表示此路不通。

给出一行N个数表示借助该点,所需额外权值。

接下来给出起点终点,求任意两点,最短路路径 及其 最小权值。


思路:

最短路路径输出,顺便找到字典序最小,额外开一个path[u][v] 数组,记录u到v的下一个需要行走的点,然后循环查找。

关于字典序最小,见代码。


代码:

#include<stdio.h>
#include<string.h>

#define For(a,b,c) for(int a = b; a <= c; a++)
#define mem(a,b) memset(a,b,sizeof(a))

int N, M, ans;
int e[105][105], fee[105];
int path[105][105];

void bfs(int u, int v)
{
    printf("Path: %d",u);
    if(u == v) {printf("\n"); return;} //u == v 只输出一点
    int now = path[u][v];
    while(1)
    {
        printf("-->%d",now);
        if(now == v) break;
        now = path[now][v];
    }
    printf("\n");
}

int flody()
{
    For(k,1,N)
    {
        For(i,1,N)
        {
            For(j,1,N)
            {
                if(e[i][j] == e[i][k] + e[k][j] + fee[k])
                {
                    if(path[i][j] > path[i][k])//找到字典序最小的路
                        path[i][j] = path[i][k];
                }
                if(e[i][j] > e[i][k] + e[k][j] + fee[k])
                {
                    e[i][j] = e[i][k] + e[k][j] + fee[k];
                    path[i][j] = path[i][k];
                }
            }
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d",&N),N)
    {
        For(i,1,N)
        {
            For(j,1,N)
            {
                scanf("%d",&e[i][j]);
                if(e[i][j] == -1) e[i][j] = path[i][j] = 0x3f3f3f3f;
                else path[i][j] = j;
            }
        }
        For(i,1,N) scanf("%d",&fee[i]);
        flody();
        int a, b;
        while(scanf("%d%d",&a,&b),a+b+2)
        {
            printf("From %d to %d :\n",a,b);

            bfs(a,b);

            printf("Total cost : %d\n\n",e[a][b]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/j2_o2/article/details/80263346