TOJ1837 Minimum Transport Cost floyd

1837: Minimum Transport Cost

描述

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

输入

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1  b2  ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

输出

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

样例输入

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

样例输出

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

花费一样的,要记录字典序小的。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int a[1005][1005],b[1005]; 
int pre[1005][1005];//路径 
int main()
{
	int n,i,j,k,x,y;
	while(scanf("%d",&n))
	{
		if(n==0)break;
		memset(pre,-1,sizeof(pre));
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				scanf("%d",&a[i][j]);
				 if(a[i][j]==-1)
     				a[i][j]=inf;
			}
		}
		for(i=1;i<=n;i++)
		scanf("%d",&b[i]);
		
	    for(i=1;i<=n;i++)
	    {
	        for(j=1;j<=n;j++)
	        {
	            pre[i][j]=j;
	        }
	    }
        for(k=1;k<=n;k++)
        {
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    if(a[i][j]>a[i][k]+a[k][j]+b[k])
                    {
                        a[i][j]=a[i][k]+a[k][j]+b[k];
                        pre[i][j]=pre[i][k];
                    }
                    else if(a[i][j]==a[i][k]+a[k][j]+b[k])
                    {
                        if(pre[i][j]>pre[i][k])
                        {
                            a[i][j]=a[i][k]+a[k][j]+b[k];
                            pre[i][j]=pre[i][k];
                        }
                    }
 
                }
            }
        }		
		while(scanf("%d%d",&x,&y)!=EOF)
		{
			if(x==-1&&y==-1)break;
			printf("From %d to %d :\n",x,y);
            if(x==y)
            {
                printf("Path: %d\n",x);
            }
            else
            {
                printf("Path: %d",x);
                int t=x;
                while(t!=y)
                {
                	printf("-->%d",pre[t][y]);
                    t=pre[t][y];
                }
                printf("\n");
            }
            printf("Total cost : %d\n\n",a[x][y]);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/thewise_lzy/article/details/81185407