HDU--1385--最短路径扩展

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.
 

Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0
Sample Output
From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17
#include<cstdio>
#include<cstring>
#define N 550
#define inf 0x3fffffff
int dis[N][N],path[N][N];
int b[N];
int n;
void floyd(){
    int i,j,k;
    for(k=1;k<=n;k++)
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++){
                if(dis[i][k]==inf||dis[k][j]==inf)continue;
                int tmp=dis[i][k]+dis[k][j]+b[k];
                if(dis[i][j]>tmp){
                    dis[i][j]=tmp;
                    path[i][j]=path[i][k];
                }
                else if(dis[i][j]==tmp&&path[i][j]>path[i][k]) //同时判断字典序是否最小
                    path[i][j]=path[i][k];
            }
}
int main(){
    int i,j,k;
    while(scanf("%d",&n),n){
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++){
                scanf("%d",&dis[i][j]);
                if(dis[i][j]==-1)dis[i][j]=inf;
                path[i][j]=j;
            }
        for(i=1;i<=n;i++)
            scanf("%d",&b[i]);
        floyd();
        int s,t;
        while(scanf("%d%d",&s,&t),s!=-1&&t!=-1){
            printf("From %d to %d :\n",s,t);
            printf("Path: ");
            printf("%d",s);
            k=s;
            while(k!=t){
                k=path[k][t];
                printf("-->%d",k);
            }
            printf("\n");
            printf("Total cost : %d\n\n",dis[s][t]);
        }
    }
    return 0;
}
发布了150 篇原创文章 · 获赞 73 · 访问量 6566

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104353692