HDU 1385 Minimum Transport Cost(floyd)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/changjiale110/article/details/80191276

Minimum Transport Cost
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12419 Accepted Submission(s): 3521

Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 … a1N
a21 a22 … a2N
……………
aN1 aN2 … aNN
b1 b2 … bN

c d
e f

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output
From c to d :
Path: c–>c1–>……–>ck–>d
Total cost : ……
……

From e to f :
Path: e–>e1–>……….–>ek–>f
Total cost : ……

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output
From 1 to 3 :
Path: 1–>5–>4–>3
Total cost : 21

From 3 to 5 :
Path: 3–>4–>5
Total cost : 16

From 2 to 4 :
Path: 2–>1–>5–>4
Total cost : 17

有N个城市,然后直接给出这些城市之间的邻接矩阵,矩阵中-1代表那两个城市无道路相连,其他值代表路径长度。

如果一辆汽车经过某个城市,必须要交一定的钱(可能是过路费)。

现在要从a城到b城,花费为路径长度之和,再加上除起点与终点外所有城市的过路费之和。

求最小花费,如果有多条路经符合,则输出字典序最小的路径。

code:

#include <iostream>
#include <string.h>
#include <algorithm>
//#include <bits/stdc++.h>
#include <queue>
#include <cstdio>
using namespace std;
int Map[1003][1003];
const int inf = 9999999;
int path[1003][1003];
int val[1003];
int n;
void floyd()
{
    for (int k=0; k<n; k++)
    {
        for (int i=0; i<n; i++)
        {
            for (int j=0; j<n; j++)
            {
                if (Map[i][j]>Map[i][k]+Map[k][j]+val[k])
                {
                    Map[i][j]=Map[i][k]+Map[k][j]+val[k];
                    path[i][j] = path[i][k];
                }
                else if (Map[i][j]==Map[i][k]+Map[k][j]+val[k]&&path[i][j]>path[i][k])
                {
                    path[i][j] = path[i][k];
                }
            }
        }
    }
}
int main()
{
    while (scanf("%d",&n),n!=0)
    {
        for (int i=0; i<n; i++)
        {
            for (int j=0; j<n; j++)
            {
                scanf("%d",&Map[i][j]);
                if (Map[i][j]==-1)
                    Map[i][j] = inf;
                path[i][j] = j;
            }

        }

        for (int i=0; i<n; i++)
        {
            scanf("%d",&val[i]);
        }
        floyd();

        int start, ended;
        while (~scanf("%d%d",&start,&ended))
        {
            if (start==-1&&ended==-1)
                break;
            printf("From %d to %d :\n",start,ended);
            printf("Path: ");
            int u = start-1, v = ended-1;
            printf ("%d",u+1);
            while (u!=v)
            {
                printf ("-->%d",path[u][v]+1);
                u = path[u][v];
            }
            printf("\nTotal cost : %d\n\n", Map[start-1][ended-1]);
        }

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/changjiale110/article/details/80191276