HDU - 1385 Minimum Transport Cost

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题解:给出n个城市和每个城市到另一个的费用,输出给出的一个城市到另一个城市的费用,如果价值一样的输出最小字典序的路径。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int n,dis[1010][1010],a[1010];
int hou[1010][1010];
void lin()
{
    int i,j,k;
    for(k=1; k<=n; k++)
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(dis[i][j]>dis[i][k]+dis[k][j]+a[k])
                {
                    dis[i][j]=dis[i][k]+dis[k][j]+a[k];
                    hou[i][j]=hou[i][k];
                }
                else
                {
                    if(dis[i][j]==dis[i][k]+dis[k][j]+a[k])
                        if(hou[i][j]>hou[i][k])
                            hou[i][j]=hou[i][k];
                }
            }
        }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(hou,0,sizeof(hou));
        int i,j,x,y;
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                scanf("%d",&dis[i][j]);
                if(dis[i][j]==-1)
                    dis[i][j]=inf;
                hou[i][j]=j;
            }
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
        lin();
        while(scanf("%d%d",&x,&y)&&(x!=-1||y!=-1))
        {
            printf("From %d to %d :\n",x,y);
            printf("Path: %d",x);
            int tx=x,ty=y;
            while(tx!=ty)
            {
                printf("-->%d",hou[tx][ty]);
                tx=hou[tx][ty];
            }
            printf("\nTotal cost : %d\n\n", dis[x][y]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GJLfly/article/details/81747035