POJ - 2533 Longest Ordered Subsequence(动态规划)

POJ - 2533 Longest Ordered Subsequence(动态规划)

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 59359   Accepted: 26610

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion


#include<stdio.h>
int max(int x,int y)
{  int t;
 if(x>y)t=x;
 else t=y;
 return t;
}
int main()
{   int dp[10000],a[10000];
    int i,j,N,ans=1;
    scanf("%d",&N);
    for(i=1;i<=N;i++)
    scanf("%d",&a[i]);
  for(i=1;i<=N;i++)
  {
       dp[i]=1;
    for(j=1;j<i;j++)
     {
        if(a[j]<a[i])
       dp[i]=max(dp[i],dp[j]+1);
     }
  }
     for(i=1;i<=N;i++)
  {
    ans=max(ans,dp[i]);
  }
printf("%d",ans);
 return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/79839637
今日推荐