hduoj 1072Nightmare

http://acm.hdu.edu.cn/showproblem.php?pid=1072

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14014    Accepted Submission(s): 6800


 

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

 

Sample Input

 

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1

 

Sample Output

 

4 -1 13

记忆化宽索,减除不必要的搜索 不必要的搜索有:1.该坐标不是出口且该到达该坐标的时候炸弹还剩一秒,

                                                                                2.在该点已经搜索且这次到达该点的炸弹倒计时小于等于上次到达该点的倒计时

                                                                                3.。。。。。没有三了

#include<stdio.h>
///扩展欧几里德,不会
#include<bits/stdc++.h>
#include <iostream>
using namespace std;
#define ll long long
int er;
int z;
int l=0,r=er;
int a[303][303];///记录地图
int b[303][303]={0};///表示该坐标是否被走过,
                    ///或者这次走的 与上回走过的倒计时谁大,
                    ///这次大?更新,上次大?不更新
                    
int c[303][303]={0};///表示用的时间
int n,m;///n行m列
struct node
{
    int x,y;
};     ///该点坐标
queue<node>q;///队列
int  juge(int x,int y,int z,int w)///z用来表示来源坐标的炸弹倒计时  ,  w用来表示来源坐标的步数
{
    if(x>n||x<=0||y>m||y<=0||a[x][y]==0||z==1)///不可能的,优化
        return 0;///不可能到达出口,返回0


    if(a[x][y]==3) return w+1;///到达终点,返回步数
    if(b[x][y]<z-1)
    {///没走过或者走过了但是这个更优化
        node bx;
        bx.x=x;
        bx.y=y;
        q.push(bx);///加入队列
        if(a[x][y]==4) b[x][y]=6;///重置炸弹
        else b[x][y]=z-1;
        c[x][y]=w+1;///步数加一
    }
    return 0;///没到 返回0;          
}
int bfs(int x,int y) 
{
    while(!q.empty())  q.pop();
    node ax;
    ax.x=x;
    ax.y=y;
    q.push(ax);
    while(!q.empty())
    {
        ax.x=q.front().x;
        ax.y=q.front().y;
        q.pop();
        int f;
        f=juge(ax.x+1,ax.y,b[ax.x][ax.y],c[ax.x][ax.y]);
        if(f) return f ;
        f= juge(ax.x-1,ax.y,b[ax.x][ax.y],c[ax.x][ax.y]);
        if(f) return f;
        f= juge(ax.x,ax.y+1,b[ax.x][ax.y],c[ax.x][ax.y]);
        if(f)return f;
        f=juge(ax.x,ax.y-1,b[ax.x][ax.y],c[ax.x][ax.y]);
        if(f)return f;

    }
    return -1;
}
 int main(){
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int fx,fy,enx,eny;
        scanf("%d%d",&n,&m);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&a[i][j]);///
                if(a[i][j]==2)
                {
                    fx=i;
                    fy=j;
                }
            }
        }
      //  printf("%d  %d\n",fx,fy);
        b[fx][fy]=6;
        int w=bfs(fx,fy);
        printf("%d\n",w);
        //for(int i=1;i<=n;i++)
        //{
           // for(int j=1;j<=m;j++)
           // {
           //     printf("%d ",b[i][j]);
          //  }
          //  printf("\n");
       // /}
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/henu_1710252529/article/details/82109718