poj3176Cow Bowling数塔——dp

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/dpdpd/article/details/51853665

Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16987 Accepted: 11323
Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

      7



    3   8



  8   1   0



2   7   4   4

4 5 2 6 5
Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output

Line 1: The largest sum achievable using the traversal rules
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output

30
Hint

Explanation of the sample:

      7

     *

    3   8

   *

  8   1   0

   *

2   7   4   4

   *

4 5 2 6 5
The highest score is achievable by traversing the cows as shown above.

扫描二维码关注公众号,回复: 2947619 查看本文章

树状dp一点都看不懂,然后就想把dp学一下。。。感觉自己也是萌萌哒。

寒假的时候看了dp 的概念。。。然而并没有什么卵用。现在做做题目,好像找到了诀窍。
dp我觉得就是一层一层的深入进去。在当前这个状态找到前一个状态的解。感觉很厉害。如果还有碰到题目再加进去,做一个dp的总结,现在只是有点感觉。。。

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<cmath>
#include<map>
using namespace std;
int dp[500][500];
int main()
{   
    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<=i;j++)
            cin>>dp[i][j];
        }
        for(int i=n-1;i>=0;i--)
        {
            for(int j=0;j<=i;j++)
            {
                dp[i][j]=dp[i][j]+max(dp[i+1][j+1],dp[i+1][j]); //你现在这个节点的值加上你下面那个节点的最优解
            }
        }
        cout<<dp[0][0]<<endl;
    }
}

题目提交地址:http://poj.org/problem?id=3176

猜你喜欢

转载自blog.csdn.net/dpdpd/article/details/51853665