数塔(DP)

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的: 

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少? 
 
已经告诉你了,这是个DP的题目,你能AC吗?
Input输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。 
Output对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。 
Sample Input
1
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
Sample Output
30

#include <iostream>

#include <string.h>
using namespace std;
const int MAXX = 105;
int tower[MAXX][MAXX];
int max(int x, int y){
    if (x > y)return x;
    return y;
}
void solve(int n)
{
    for (int i=n-1;i>=0;--i)
    {
        for (int j=0;j<=i;++j)
        {
            tower[i][j]+=max(tower[i+1][j],tower[i+1][j+1]);
        }
    }
}
int main(){
    int c, n;
    cin >> c;
    while (c--){
        cin >> n;
        memset(tower, 0, sizeof(tower));
        for (int i = 0; i < n; ++i)
        {
            for (int j = 0; j < n; ++j){
                if (i >= j)
                cin >> tower[i][j];
            }
        }
        solve(n);
        cout<<tower[0][0];
    }
}

猜你喜欢

转载自blog.csdn.net/zoweiccc/article/details/64444121
今日推荐