数塔 DP

A - 数塔

 
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:  有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?    已经告诉你了,这是个DP的题目,你能AC吗?
Input输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。  Output对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。  Sample Input
1
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
Sample Output
30


import java.util.Scanner;
import java.util.Arrays;

public class Main {

	static final int MAX = 105;

	public static void main(String[] args) {
		// TODO Auto-generated method stub

		Scanner cin = new Scanner(System.in);
		int[][] a = new int[MAX][MAX];
		int[][] dp = new int[MAX][MAX];
		int t = cin.nextInt();
		while (t-- != 0) {
			int n = cin.nextInt();
			for (int i = 1; i <= n; i++) {
				for (int j = 1; j <= i; j++) {
					a[i][j] = cin.nextInt();
				}
			}
			//对边界的处理,最后一行,下面没有元素,初始化为原来的值
			for (int i = 1; i <= n; i++) {
				dp[n][i] = a[n][i];
			}

			for (int i = n - 1; i >= 1; i--) {
				for (int j = 1; j <= i; j++) {
					//除了最后一行每个结点最大为当前结点的值加上左下或右下的值,(通过比较来确定加哪一个)
		            //循环结束后,原始图变成了最优图
					dp[i][j] = a[i][j] + Math.max(dp[i + 1][j], dp[i + 1][j + 1]);
				}

			}
			System.out.println(dp[1][1]);//递归的终止条件为顶元素

		}
	}
}



猜你喜欢

转载自blog.csdn.net/dujuancao11/article/details/79605247
今日推荐