UVA-1328:Period

UVA-1328:Period

来源:UVA

标签:字符串->KMP算法

参考资料:

相似题目:

题目

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK, that is A concatenated K times, for some string A. Of course, we also want to know the period K.

输入

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

输出

For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

输入样例

3
aaa
12
aabaabaabaab
0

输出样例

Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4

题目大意

给定一个长度为n的字符串s,求它的每个前缀的最短循环节。

解题思路

KMP算法中失配函数的应用,建议自己理解。

参考代码

#include<stdio.h>
#include<string.h>
#define MAXN 1000005

char s[MAXN];
int f[MAXN];

void getFail(char *s){
    int n=strlen(s);
    int j=0;
    f[0]=f[1]=0;
    for(int i=1;i<n;i++){
        j=f[i];
        while(j && s[i]!=s[j])
            j=f[j];
        f[i+1]= s[i]==s[j]? j+1: 0;
    }
}

int main(){
    int T=0;
    int n;
    while(scanf("%d",&n) && n){
        scanf("%s",s);
        getFail(s);
        printf("Test case #%d\n",++T);
        for(int i=2;i<=n;i++){
            if(f[i]>0 && i%(i-f[i])==0 )
                printf("%d %d\n",i, i/(i-f[i]));
        } 
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/81814611
今日推荐