poj1328 贪心


poj1328  Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 101197   Accepted: 22509

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1
1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

每个岛看作一个点,情况1.如果雷达的扫描范围d小于到岛的距离的话,自然是无解了。情况2.但如果,雷达的扫描范围d大于到岛的距离的话,就要分一个雷达可以扫描几个岛了。以此为切入点。

想放最少的雷达,那么岛的范围有重合的话,在最后一个重合的始端放一个雷达就可以。

范围有无重合,就看前一个岛和后一个岛在x轴的结束点和开始点的位置关系。



#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

struct point               //按岛在x轴上的范围的左开始点从左到右 大小排序
{
	int x,y;
	double e,s;
	bool operator < (const point a) const{
	return e<a.e;
	}
}p[1010];
int main()
{
	int n;
	double d;
	int kase=0;                 //case
	while (cin>>n>>d&&(n||d))
	{
		bool flag=false;       //为后面1 2情况准备
		for (int i=0;i<n;i++)
		{
			cin>>p[i].x >>p[i].y;
			if (fabs(p[i].y)>d)
			{
				flag=true;    //情况1
			}
			else                  //情况2 可以扫描到的话,x轴上开始结束点 勾股定理求得
			{
				p[i].s=p[i].x*1.0 - sqrt(d*d-p[i].y*p[i].y);
				p[i].e=p[i].x*1.0 + sqrt(d*d-p[i].y*p[i].y);
			}
		}
		cout<<"Case "<<++kase<<": ";
		if (flag)                  //情况1无解输出-1
		{
			cout<<-1<<endl;
		}
		else
		{
			int rad=1;              //只要符合情况2,开始就有雷达
			sort(p,p+n);
			double temp=p[0].e;     //令temp等于第一个岛在x轴的开始点,与后面的岛的结束点比较

			for (int i=1;i<n;i++)
			{
				if (p[i].s>temp)  //如果后一个岛的开始大于前一个岛的结束,,即范围不重合的话,放雷达
				{
					rad++;
					temp=p[i].e;
				}
				
			}
			cout<<rad<<endl;
		}
	}
}


猜你喜欢

转载自blog.csdn.net/qlu_minoz/article/details/80087919