Period (KMP)


    For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
    The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
    number zero on it.
Output
    For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input

    3
    aaa
    12
    aabaabaabaab
    0

Sample Output

    Test case #1
    2 2
    3 3

    Test case #2
    2 2
    6 2
    9 3
    12 4

题意:从第一个元素开始往后找,看是否存在循环节,如果存在输出此时串的长度及循环节的次数。比如aaa,前两个元素aa存在循环节a,循环了两次;aaa的时候,循环了三次。(可能我表达的不是很清楚,如果实在不理解就先看看代码的实现)

#include<stdio.h>
#include<string.h>
char a[1000010];
int n,next[1000010];
void get_next()
{
	int i = 1, j = 0;
	next[0] = 0;
	while(i < n)
	{
		if(j == 0 && a[i] != a[j])
		{
			next[i] = 0;
			i ++;
		}
		else if(j > 0 && a[i] != a[j])
			j = next[j-1];
		else
		{
			next[i] = j + 1;
			i ++; j ++;
		}
	}
}
int main()
{
	int t,i,k;
	while(scanf("%d",&n),n != 0)
	{
		k = 1;
		scanf("%s",a);
		get_next();
		
		printf("Test case #%d\n",k ++);
        for(i = 1; i <= n; i ++)
        {
        	t = i - next[i-1];
        	if(t != i && i % t == 0)
        		printf("%d %d\n",i,i/t);
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81178029