Q - Period

Q - Period

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题目大意:

给定一个长度和对应长度的字符串

要求给出 从 2<=i<=N 的每一个前缀中

如果这个前缀是循环子串的话,要求给出循环次数并输出

思路:

求 kmp算法中的 next 数组 代码里叫  pre  其实性质都一样

pre[i] 表示的是第 i个子串对应的 非本身的 前缀和后缀的相同的最大长度

得到 next(pre) 数组后 ,遍历每一个i   

令  j = i-pre[i]

若  i%j == 0 的话  则,这个为对应的循环子串,  那么  i/j 即为答案

code:

#include<iostream>
using namespace std;
int N;
const int MAXN = 1000009;
char map[MAXN]; 
char temp[MAXN];
int pre[MAXN];

void getPre(){
	
	pre[1] = 0;
	for(int i=2;i<=N;i++){
		int k = pre[i-1];
		while(1){
		
			if(map[i] == map[k+1]){
				pre[i] =  k+1;
				break;
			}
			if(k==0){
				pre[i] = 0;
				break;
			}
			k = pre[k];	
		}
	}
	
}

int main(){
	
	int caseT = 0;
	while(scanf("%d",&N)!=EOF){
		if(N==0) break;
		caseT++;
		getchar();
		for(int i=1;i<=N;i++){
			scanf("%c",&map[i]);
		}
		map[N+1] = 95; 
		getPre();
		
		printf("Test case #%d\n",caseT);
		for(int i=1;i<=N;i++){
			int j = i - pre[i];
			if(pre[i]>0 && i%j==0)
				printf("%d %d\n",i,i/j);
		}
		printf("\n");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Willen_/article/details/87905741
Q A
q