E - Period

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

这题的意思就是在文本串中找循环的串,输出最后一个字符位置和循环节的长度

//e
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e6+10;
char s[maxn];
int ne[maxn];
void get(int len)
{
	ne[0]=-1;
	int j=-1;
	for(int i=0;i<len;)
	{
		if(j==-1||s[i]==s[j]) ne[++i]=++j;
		else j=ne[j];
	}
}
int main()
{
	int t;
	int cas=1;
	while(~scanf("%d",&t)&&t)
	{
		scanf("%s",s);
		int len=strlen(s);
		get(len);
		
		printf("Test case #%d\n",cas++); 
		for(int i=2;i<=len;i++) 
		{
			if(ne[i]>0)
			{
				int n=i-ne[i];//判断当前的(0到i)循环节长度 
				if(i%n==0) //中间没有其他杂物  !=0就不是循环节,直接continue; 
				 printf("%d %d\n",i,i/n);
			}
		}
		printf("\n");
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41286356/article/details/85028992