poj 1328(贪心)

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 96097   Accepted: 21364

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

       在这个题中可以以小岛为圆心画圆。这样可以得到两个与x轴的交点,那么这个间距就是满足要求的雷达。  那么我们可以通过贪心区间来求解。

    

    由此,要使放置雷达的个数最少。将线段按左端点递增排序,采用贪心策略,对于下一个小岛能利用之前的雷达就利用,条件为,下一条线段的左端点小于公用范围(线段)右边界。否则雷达+1,并以该线段作为新雷达的公用范围。

注意:1.共用范围(线段)是不断减小的。所以右端点取最小。

AC代码(很大的卡点----如果使用cin cout  会卡时间)

#include<map>
#include<math.h>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX_N=100000+50;
const int INF=0x3f3f3f3f;

struct Node
{
	double x,y;
	//friend bool operator < (Node node)
	//{
	//	n1 < node.n1;
	//}
};
bool cmp(Node a,Node b)
{
	return a.x<b.x;
}

int main()
{
	int n,d;
	vector<Node> v;
	int k = 1;
	while(scanf("%d%d",&n,&d)!=EOF)
	{
		if(n == 0&&d == 0) break;
		v.clear();
		bool flag = false;
		for(int i = 0; i < n; i++)
		{
			Node s1;
			double x,y;
			scanf("%lf%lf",&x,&y);
			if(y > d ) flag = true;
			double x_num = sqrt(d*d-y*y);
			s1.x = x-x_num;
			s1.y = x+x_num;
			v.push_back(s1);
		}
		if(flag)
		{
			printf("Case %d: -1\n",k++);
		}
		else
		{
			sort(v.begin(),v.end(),cmp);
			double St_y = v[0].y;
			int ans = 1;
			for(int i = 1; i < v.size(); i++)
			{
				if(v[i].x > St_y)
				{
					ans++;
					St_y = v[i].y;
				}
				else
				{
					if(v[i].y < St_y)
					{
						St_y = v[i].y;
					}
				}
			}
			printf("Case %d: %d\n",k++,ans);			
		}

	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40984919/article/details/80334634