HDU 1115 Lifting the Stone(多边形重心)

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9476    Accepted Submission(s): 3977

Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 

Sample Input

2 
4 
5 0
0 5 
-5 0 
0 -5 
4 
1 1 
11 1 
11 11 
1 11

Sample Output

0.00 0.00
6.00 6.00

Source

Central Europe 1999

Recommend

Eddy

这是多边形求重心问题:

n剖分成N-2个三角形,分别求出其重心和面积,这时可以想象,原来质量均匀分布在内部区域上,而现在质量仅仅分布在这N-2个重心点上(等假变换),这时候就可以利用刚才的质点系重心公式了。

不过,要稍微改一改,改成加权平均数,因为质量不是均匀分布的,每个质点代表其所在三角形,其质量就是该三角形的面积(有向面积),——这就是权

关于为什么是有向面积:https://blog.csdn.net/tigercoder/article/details/70161646

①质量集中在顶点上。n个顶点坐标为(xi,yi),质量为mi,则重心

 X = ∑( xi×mi ) / ∑mi

 Y = ∑( yi×mi ) / ∑mi

②质量分布均匀。这个题就是这一类型,算法和上面的不同。

  特殊地,质量均匀的三角形重心:

  X = ( x0 + x1 + x2 ) / 3  

  Y = ( y0 + y1 + y2 ) / 3

/*
求面积 求重心
*/
#include <bits/stdc++.h>
using namespace std;
#define maxn 1005000
struct point
{
    double x,y;
};
//struct Triangle{
//    double a,b;//重心
//    double s;//面积
//}tt[maxn];
double area(point a,point b,point c)//计算面积
{
    //ab X ac
    double s=0;
    double x1,y1,x2,y2;
    x1=b.x-a.x;
    y1=b.y-a.y;
    x2=c.x-a.x;
    y2=c.y-a.y;
    s=(x1*y2-x2*y1)/2.0;
    return s;
}
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        point p0,p1,p2;
        scanf("%d",&n);
        scanf("%lf%lf",&p0.x,&p0.y);//第一个
        scanf("%lf%lf",&p1.x,&p1.y);
        double xx=0,yy=0,mm=0;
        n=n-2;
        //cout<<n<<endl;
        while(n--)
        {
            double s=0;
            scanf("%lf%lf",&p2.x,&p2.y);
            s=area(p0,p1,p2);//面积
            mm+=s;
            xx+=(p0.x+p1.x+p2.x)*s;
            yy+=(p0.y+p1.y+p2.y)*s;
            p1=p2;

        }
        xx=xx/mm/3.0;
        yy=yy/mm/3.0;
        printf("%.2lf %.2lf\n",xx,yy);
    }return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81567964
今日推荐