Lifting the Stone 7.1.3

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 155    Accepted Submission(s): 88

 
Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.
Output

            Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.
Sample Input
2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11
Sample Output
0.00 0.00
6.00 6.00
 
   题意是求一个多边形的重心。
   将这个多边形分成以p[0]为公共顶点的n-2个三角形。求出每个三角形的面积(包含正负,因为其可能是凹多边形),三角形的重心是(x1+x2+x3)/3, 对所有这样的三角形面积加权
平均后,即得重心的位置。
 
 
      
#include<cstdio>
using namespace std;

const int MAXN = 1000000 + 10;
struct Point{
	int x, y;
}p[MAXN];
double cross(Point pi, Point pj, Point pk){
	//(pj - pk)*(pi - pk)
	return (pj.x - pk.x) * (pi.y - pk.y) - (pj.y - pk.y) * (pi.x - pk.x);
}
int main(){
	int t, n, a, b;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(int i = 0; i < n; i++){
			scanf("%d%d", &a, &b);
			p[i].x = a;
			p[i].y = b;			
		}
		double sumarea=0.0, sumx=0.0, sumy=0.0;
		for(int i = 1; i < n-1; i++){
			double area = cross(p[i], p[i+1], p[0]);
			double sx = p[i].x + p[i+1].x + p[0].x;
			double sy = p[i].y + p[i+1].y + p[0].y;
			sumarea += area;
			sumx += sx * area;
			sumy += sy * area;
		}
		printf("%.2lf %.2lf\n", sumx / sumarea / 3, sumy / sumarea / 3);
	}	
	return 1;
}

猜你喜欢

转载自blog.csdn.net/bruce_teng2011/article/details/38644879
今日推荐