Lifting the Stone HDU - 1115 (求多边形的重心)

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 

Sample Input

2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11

Sample Output

0.00 0.00
6.00 6.00

将多边形分割为三角形的并,对每个三角形求重心(三角形重心即三点坐标的平均值),然后以三角形的有向面积为权值求加权平均即可。

特别提一个三角形面积求解公式(我不记得有这个公式):S = ((x2-x1)*(y3-y1)-(x3-x1)*(y2-y1))/2.0   ;

#include <iostream>
#include <cstdio>
using namespace std;
struct point
{
    double x,y;
};
int main()
{
    int T, n, i;
    point p0, p1, p2;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        double sumx = 0, sumy = 0, sum = 0, temp;
        scanf("%lf%lf", &p0.x, &p0.y);
        scanf("%lf%lf", &p1.x, &p1.y);
        for (i=2; i<n; i++)
        {
            scanf("%lf%lf", &p2.x, &p2.y);
            temp = ((p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y))/2.0;
            sum += temp; //三角形面积和
            sumx += ((p0.x+p1.x+p2.x) * temp);
            sumy += ((p0.y+p1.y+p2.y) * temp);
            p1.x = p2.x;
            p1.y = p2.y;
        }
        printf("%.2lf %.2lf\n", sumx/sum/3, sumy/sum/3);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Nothing_227/article/details/81202497
今日推荐