(找循环节)Number Sequence

题目:

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5

参考https://blog.csdn.net/hurmishine/article/details/51333005

为什么循环结是49?
很简单,因为
f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
=A * f(n - 1)mod 7 + B * f(n - 2)mod 7
7的余数可能有:0 1 2 3 4 5 6
所以A * f(n - 1)mod 7有7种情况
B * f(n - 2)mod 7有7种情况
那么整体就有7*7种情况

所以以后遇见这种mod小的,用循环结做就ok

参考代码:

#include <iostream>
using namespace std;
int arr[50];
int main()
{
    int n,a,b;
    arr[1]=arr[2]=1;
    while(cin>>a>>b>>n)
    {
        if(a==0&&b==0&&n==0)
            break;
        int minn=n<50?n:50;//一个小小的优化
        for(int i=3; i<=minn; i++)
        {
            arr[i]=(a*arr[i-1]+b*arr[i-2])%7;
        }
        cout<<arr[n%49]<<endl;

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40828914/article/details/81807581