HDU Problem - 1969 Pie(二分,精度)

题目链接

Problem Description

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

AC

  • 二分枚举,处理精度的时候不能转化为整数
#include <iostream>
#include <stdio.h>
#include <map>
#include <vector>
#include <queue>
#include <algorithm>
#include <cmath>
#define N 10005
#define ll long long
#define P pair<int, int>
#define mk make_pair
using namespace std;
double pi = asin(1) * 2;
double a[N];
int main() {
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
#endif
    int t;
    scanf("%d" ,&t);
    while (t--) {
        int n, f;
        scanf("%d%d", &n, &f);
        ++f;
        for (int i = 0; i < n; ++i) {
            int t;
            scanf("%d", &t);
            a[i] = t * t * pi;
        }
        sort(a, a + n);
        double l = 0, r = 3140000000;
        while ((r - l) > 1e-5) {
            double mid = (r + l) / 2;
            int sum = 0;
            for (int i = 0; i < n; ++i) {
                sum += a[i] / mid;
            }
            if (sum >= f)
                l = mid;
            else
                r = mid;
        } 
        printf("%.4f\n", l);
    }   

    return 0;
} 

猜你喜欢

转载自blog.csdn.net/henuyh/article/details/81749929