hdu_1969 二分

http://acm.hdu.edu.cn/showproblem.php?pid=1969

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different. 

Input

One line with a positive integer: the number of test cases. Then for each test case: 
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. 
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies. 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

这道题,给你n个饼和这些饼的半径,然后有f个朋友要和你分饼,加上你一共f+1个人分n个饼,但是他们要求所分得的不妨一定要同等大小,而且要完整,

比如说,两个饼,面积为4和3,有两个朋友要和你分饼,所以加上你一共有三个人吃这个饼,那么,每个人最大分得的面积是2,:面积为4的饼被分成2个面积为2的饼,面积为三的饼被分为面积为2和面积为1(面积为1的饼扔了,没人吃)的饼,所以答案是2

首先,算出各个饼的总面积,

然后求出最小下限=最大饼面积/(f+1)

最大上限=总面积/(f+1)

然后用二分法搜索面积////以上数据类型为double型

///切批萨
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;


#define mx 10020
double pi=acos(-1.0);
double a[mx];
int main()
{
      int t;
      ios::sync_with_stdio(false);
      cin>>t;
      while (t--)  {
            int n,f;
            cin>>n>>f;
            f++;
            double sum;
            double maxn=sum=0;
            for(int i=1;i<=n;i++)
            {
                  cin>>a[i];
                  a[i]*=a[i];
                  a[i]*=pi;
                  sum+=a[i];
                  maxn=max(a[i],maxn);
            }
            // for(int i=1;i<=n;i++)
            // {
            //       printf("%lf  ",a[i] );
            // }cout<<endl;
            //double siz=0;
            int ans=0;///批萨的数量,大于f符合规矩,小于f不符合规矩,尺寸有点小
            double le=maxn/f,ri=sum/f;
            //int e=9999;
            while (le<ri-0.00001) {
                  double mid=le+ri;
                  mid/=2;///批萨的尺寸
                  ans=0;
                  for(int i=1;i<=n;i++)
                  {
                        ans+=(int)floor(a[i]/mid);
                  }
                  if(ans>=f)///尺寸有点小
                  {
                        le=mid;
                        //siz=siz>mid?siz:mid;
                  }
                  else
                  {
                        ri=mid;
                  }


            }
            printf("%.4lf\n",le );


      }

      return 0;
}

猜你喜欢

转载自blog.csdn.net/henu_1710252529/article/details/81806853