HDU - 1969 Pie

问题描述:

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

输入说明:

One line with a positive integer: the number of test cases. Then for each test case:
—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

输出说明:

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

SAMPLE INPUT:

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

SAMPLEOUTPUT:

25.1327
3.1416
50.2655

思路:

题意是要把N张饼,分给F个人,因为自己也要分到一份,所以数量要加一。输入的数据是半径,所以在输入的同时,去乘上π得到面积,注意这里的π需要通过反三角来求得,然后将所有的面积从大到小排序,以最大饼的面积作为终点,0作为起点开始二分,对于每一个面积都要进行考虑,判断其能否分给所有的朋友,注意要精确到1e-5

AC代码:

#include <bits/stdc++.h>
#define pi 4*atan(1.0)
using namespace std;
double a[100000];
int n,m,i;
int f(double middle)
{
    
    
    int sum=0;
    for(i=0;i<n;i++)
    {
    
    
        int temp=a[i]/middle;
        sum+=(int)temp;
        if(sum>=m)
            return 1;
    }
    return 0;
}
int main()
{
    
    
    int t,x,i,j;
    double l,r,middle;
    cin>>t;
    while(t--)
    {
    
    
        memset(a,0,sizeof(a));
        cin>>n>>m;
        m++;
        for(i=0;i<n;i++)
        {
    
    
            cin>>x;
            a[i]=x*x*pi;
        }
        sort(a,a+n,greater<int>());
        l=0.0;
        r=a[0]*1.0;
        n=min(n,m);
        while(r-l>1e-5)
        {
    
    
            middle=(r+l)/2;
            if(f(middle)==1)
                l=middle;
            else
                r=middle;
        }
        cout<<fixed<<setprecision(4)<<l<<endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/m0_51727949/article/details/115177280
pie