HDU - 1086 (简单几何,判断直线之间的交点) ʕ •ᴥ•ʔ

Problem Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the number of intersections, and one line one case.

扫描二维码关注公众号,回复: 2826687 查看本文章

Sample Input

 

2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

Sample Output

 

1 3

题目大意:多次输入,输入一个n,之后是n条直线(x1,y1,x2,y2)

判断这些直线有多少交点,重复的交点也算上

判断AB和CD两线段是否有交点:  同时满足两个条件:('x'表示叉积)   1.C点D点分别在AB的两侧.(向量(ABxAC)*(ABxAD)<=0)   2.A点和B点分别在CD两侧.(向量(CDxCA)*(CDxCB)<=0)     3.  向量(ABxAC)*(ABxAD)<0代表在直线两侧, =0代表在直线上。

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string.h>
#include <map>
#define ll long long
#define pi acos(-1.0)
using namespace std;
struct ac
{
	double x1,y1,x2,y2;
	
}r[110];
int jude(ac a,ac b)
{
	if(((b.x2-b.x1)*(a.y1-b.y1)-(a.x1-b.x1)*(b.y2-b.y1)) * ((b.x2-b.x1)*(a.y2-b.y1)-(a.x2-b.x1)*(b.y2-b.y1))>0)
	return 0;
	if(((a.x2-a.x1)*(b.y1-a.y1)-(b.x1-a.x1)*(a.y2-a.y1)) * ((a.x2-a.x1)*(b.y2-a.y1)-(b.x2-a.x1)*(a.y2-a.y1))>0)
	return 0;
	return 1;
		
} 
int main()
{
	ios::sync_with_stdio(false);
	int n;
	while(cin>>n)
	{
		if(n==0)
		break;
		for(int i=0;i<n;i++)
		{
			cin>>r[i].x1>>r[i].y1>>r[i].x2>>r[i].y2;
		}
		int ans=0;
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
				if(jude(r[i],r[j]))
				ans++;
			}
		}
		cout<<ans<<endl;
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81775064
今日推荐