HDU 1086 You can Solve a Geometry Problem too(线段交点)

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12525    Accepted Submission(s): 6154


Problem Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 

 Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.

 Output

For each case, print the number of intersections, and one line one case.

 Sample Input

2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

 Sample Output

1 3

Author

lcy

 求线段的交点。

判断ABCD两线段是否有交点:
 同时满足两个条件:
('x'表示叉积)
 
 1CD点分别在AB的两侧.(向量(ABxAC)*(ABxAD)<=0)
 
 2A点和B点分别在CD两侧.(向量(CDxCA)*(CDxCB)<=0)
    3. 
向量(ABxAC)*(ABxAD)<0代表在直线两侧, =0代表在直线上。

#include <bits/stdc++.h>
using namespace std;
#define maxn 105
int n;
struct point
{
    double x,y;
    point friend operator -(point a,point b)
    {
        return {a.x-b.x,a.y-b.y};
    }

};
struct edge//线段
{
    point a,b;
}p[maxn];
//double X(point a,point b)//点 叉乘
//{
 //   return a.x*b.y-b.x*a.y;
//}

//double multi(point a1,point a2,point a3)//一个点 一条边
//{
 //   return X(a2-a1,a3-a1);
//}
double judge(point a,point b,point c)//判断这两条边相交
{
    double x1,y1,x2,y2;//c->>>a,b
    x1=c.x-a.x;
    y1=c.y-a.y;
    x2=c.x-b.x;
    y2=c.y-b.y;
    return (x1*y2-x2*y1);

}
int main()
{

    while(scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf%lf%lf",&p[i].a.x,&p[i].a.y,&p[i].b.x,&p[i].b.y);
        }
        int ans=0;
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                if(judge(p[i].a,p[i].b,p[j].a)*judge(p[i].a,p[i].b,p[j].b)<=0&&judge(p[j].a,p[j].b,p[i].a)*judge(p[j].a,p[j].b,p[i].b)<=0)
                ans++;
            }
        }printf("%d\n",ans);
    }return 0;
}


 

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81568220