HDU - 1086-(简单几何,判断直线之间的交点)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1086

Problem Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.

 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.

 

Output

For each case, print the number of intersections, and one line one case.

 

Sample Input

扫描二维码关注公众号,回复: 2759468 查看本文章
 

2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

 

Sample Output

 

1 3

题目大意:多次输入,输入一个n,之后是n条直线(x1,y1,x2,y2)

判断这些直线有多少交点,重复的交点也算上

计算几何的基础题,向量叉乘
                AB  CD交点判断 
                相交:
                AB *AC<=0 && AB * AD>=0  所以相乘<=0 
                同理:CD *  CB<=0 && CD * CA>=0  所以相乘<=0 
          

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 1000000007
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);
struct node{
	double x,y;
	node& operator - (node &a){
		x=x-a.x;
		y=y-a.y;
		return *this;
	}
	node (double _x=0,double _y=0):x(_x),y(_y){}
};

struct Node{
	double x1,x2,y1,y2;
}dot[110];

double cross(node a,node b)
{
	return a.x*b.y-a.y*b.x;
}

bool judge(int i,int j)
{
	if((cross(node(dot[i].x2-dot[i].x1,dot[i].y2-dot[i].y1)//第一条线 
	,node(dot[j].x1-dot[i].x1,dot[j].y1-dot[i].y1))*//第二条线 
	cross(node(dot[i].x2-dot[i].x1,dot[i].y2-dot[i].y1)//第一条线 
	,node(dot[j].x2-dot[i].x1,dot[j].y2-dot[i].y1))//第二条线 
	)<=0)
		return 1;
	else
		return 0;
}

int main()
{
	std::ios::sync_with_stdio(false);
	int n;
	while(cin>>n&&n)
	{
		for(int i=1;i<=n;++i)
		{
			cin>>dot[i].x1>>dot[i].y1>>dot[i].x2>>dot[i].y2;
//			double x0,y0,x1,y1;
//			cin>>x0>>y0>>x1>>y1;
//			dot[i].x=fabs(x1-x0);
//			dot[i].y=fabs(y1-y0);
		}
		int ans=0;
		for(int i=1;i<=n;++i)
		{
			for(int j=i+1;j<=n;++j)
			{
				/*
				AB  CD交点判断 
				相交:
				AB *AC<=0 && AB * AD>=0  所以相乘<=0 
				同理:CD *  CB<=0 && CD * CA>=0  所以相乘<=0 
				*/
				if(judge(i,j)&&judge(j,i))
					ans++;
			}
		}
		cout<<ans<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/81583717
今日推荐