A1012 The Best Rank (25)(25 分)

A1012 The Best Rank (25)(25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

思考

理解总结之后,在脑子里简化结论,快速应用,才是学习的主要方法啊。

练成反应,李长林啊。

PAT里面排名的思路竟然就和一般人排名思路不一样。

91,90,88,88,84

排名,1、2、3、3、5

而不是正常思维的1、2、3、3、4

AC代码

#include <stdio.h>
#include <stdio.h>
#include <stdlib.h>

struct Student{
    int id;
    int grade[4];
}stu[2010];

char course[4] = {'A', 'C', 'M', 'E'};
int Rank[10000000][4] = {0};
int now;

int cmp(const void* a, const void* b){
    struct Student*aa=a;
    struct Student*bb=b;
    return aa->grade[now] <bb->grade[now];//cmp函数中<在c语言对应降序,在c++里对应升序 
}
/*  为使qsort达成升序排列
    在函数cmp中,如果第一个参数小于第二个参数,它必须返回一个负值;
    如果第一个参数等于第二个参数,它必须返回0;
    如果第一个参数大于第二个参数,它必须返回一个正值。
降序则反其道而行
    */
int main(){
    int n,m;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < n; i++){
        scanf("%d%d%d%d", &stu[i].id, &stu[i].grade[1], &stu[i].grade[2], &stu[i].grade[3]);
        stu[i].grade[0] = (stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3]) / 3;
    }
    for(now = 0; now < 4; now++){
        qsort(stu, n,sizeof (struct Student), cmp);
        Rank[stu[0].id][now] = 1;
        for(int i = 1; i < n; i++){
            if(stu[i].grade[now] == stu[i - 1].grade[now]){
                Rank[stu[i].id][now] = Rank[stu[i - 1].id][now];
            }else{
                Rank[stu[i].id][now] = i + 1;//这里有点不解,逻辑似乎不对啊,这个数并非正确排名
                //Rank[stu[i].id][now] = Rank[stu[i - 1].id][now]+1;这才是对的吧,排名+1啊
            }
        }
    }
    int query;
    for(int i = 0; i < m; i++){
        scanf("%d", &query);
        if(Rank[query][0] == 0){
            printf("N/A\n");
        }else{
            int k = 0;
            for(int j = 0; j < 4; j++){
                if(Rank[query][j] < Rank[query][k]){
                    k = j;
                }
            }
            printf("%d %c\n", Rank[query][k], course[k]);
        }
    }
    return 0;
}

给出c++代码,主要是cmp函数的写法不同,因为sort函数与qsort函数要求不同

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct Student{
    int id;
    int grade[4];
}stu[2010];

char course[4] = {'A', 'C', 'M', 'E'};
int Rank[10000000][4] = {0};
int now;

bool cmp(Student a, Student b){
    return a.grade[now] > b.grade[now];
}

int main(){
    int n,m;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < n; i++){
        scanf("%d%d%d%d", &stu[i].id, &stu[i].grade[1], &stu[i].grade[2], &stu[i].grade[3]);
        stu[i].grade[0] = (stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3]) / 3;
    }
    for(now = 0; now < 4; now++){
        sort(stu, stu + n, cmp);
        Rank[stu[0].id][now] = 1;
        for(int i = 1; i < n; i++){
            if(stu[i].grade[now] == stu[i - 1].grade[now]){
                Rank[stu[i].id][now] = Rank[stu[i - 1].id][now];
            }else{
                Rank[stu[i].id][now] = i + 1;
            }
        }
    }
    int query;
    for(int i = 0; i < m; i++){
        scanf("%d", &query);
        if(Rank[query][0] == 0){
            printf("N/A\n");
        }else{
            int k = 0;
            for(int j = 0; j < 4; j++){
                if(Rank[query][j] < Rank[query][k]){
                    k = j;
                }
            }
            printf("%d %c\n", Rank[query][k], course[k]);
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/lingr7/p/9487586.html