【PAT】A1012 The Best Rank (25point(s))

A1012 The Best Rank (25point(s))

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

Code

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int maxn = 10;
const int maxn2 = 2010;
char course[4] = { 'A', 'C', 'M', 'E' };
typedef struct stu{
	char id[maxn];
	int g[4], r[4];
}stu;
stu stus[maxn2];
char sid[maxn];
int flag1 = -1;			//0-a,1-c,2-m,3-e
bool cmp(stu a, stu b){
	return a.g[flag1] > b.g[flag1];
}
void ranks(int n){
	for (flag1 = 0; flag1 < 4; flag1++){
		sort(stus, stus + n, cmp);
		stus[0].r[flag1] = 1;
		for (int i = 1; i < n; i++){
			if (stus[i].g[flag1] == stus[i - 1].g[flag1])
				stus[i].r[flag1] = stus[i - 1].r[flag1];
			else
				stus[i].r[flag1] = i + 1;
		}
	}
}
void search(int n){
	bool flag = false;
	int num, min = maxn2 + 1;
	for (int i = 0; i < n; i++){
		if (!strcmp(sid, stus[i].id)) {
			flag = true;
			for (flag1 = 0; flag1 < 4; flag1++){
				if (stus[i].r[flag1] < min){
					min = stus[i].r[flag1];
					num = flag1;
				}
			}
			break;
		}
	}
	if (flag)
		printf("%d %c\n", min, course[num]);
	else
		printf("N/A\n");
}
int main(){
	int n, m;
	scanf("%d %d", &n, &m);
	for (int i = 0; i < n; i++){
		scanf("%s %d %d %d", stus[i].id, &stus[i].g[1], &stus[i].g[2], &stus[i].g[3]);
		stus[i].g[0] = (stus[i].g[1] + stus[i].g[2] + stus[i].g[3]) / 3.0 + 0.5;			//四舍五入
	}
	ranks(n);
	for (int i = 0; i < m; i++){
		scanf("%s", sid);
		search(n);
	}
	return 0;
}

Analysis、

-已知每个人的C(C语言) M(高数) E(英语)三门课的分数,先计算其均分A。之后给出一些学号。

-求给出的学号在所有人中4个分数中的最好排名。如果给出的学号没有成绩(之前未给出),输出N/A。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103748508