PAT (Advanced Level) Practice A1012 The Best Rank (25 分)(C++)(甲级)(两种方法)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/86376380

1012 The Best Rank (25 分)
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

typedef struct Student
{
    int ID;
    int grade[4];//0123存放ACME
} Student;

Student S[2010] = {0};//最多输入2000个

int Rank[10000000][4] = {0};//用来存放每个ID在每个排序下的排名

int x = 0;//每个排序下的下标,cmp中使用

bool cmp(Student A, Student B)
{
    return A.grade[x] > B.grade[x];//动态变化
}

int main()
{
    int N = 0, M = 0;
    char Symbol[5] = "ACME";//符号
    scanf("%d %d", &N, &M);
    for(int i = 0; i<N; i++)
    {
        scanf("%d %d %d %d", &S[i].ID, &S[i].grade[1], &S[i].grade[2], &S[i].grade[3]);
        S[i].grade[0] = (int)( (double)( S[i].grade[1] + S[i].grade[2] + S[i].grade[3]) / 3.0 + 0.5 );//算平均
    }
    for(x = 0; x<4; x++)
    {
        sort(S, S+N, cmp);//排序,并设定每个排序下的下标值
        Rank[S[0].ID][x] = 1;
        for(int i = 1; i<N; i++)
        {
            if(S[i].grade[x] != S[i-1].grade[x]) Rank[S[i].ID][x] = i+1;
            else Rank[S[i].ID][x] = Rank[S[i-1].ID][x];
        }
    }
    for(int i = 0; i<M; i++)
    {
        int ID = 0;
        scanf("%d", &ID);
        int k = 0;
        if(!Rank[ID][0]) printf("N/A\n");//该ID不存在
        else//否则将其最佳排序输出以及其Symbol
        {
            for(int j = 1; j<4; j++)
            {
                if(Rank[ID][j] < Rank[ID][k])
                {
                    k = j;
                }
            }
            printf("%d %c\n", Rank[ID][k], Symbol[k]);
        }
    }
    return 0;
}


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

typedef struct Student
{
    int ID;
    int grade[4];
    int temp_rank;//本次的排名
    int best_rank;//最好的排名
    int symbol;//最好排名的symbol
} Student;

Student S[2010] = {0};

int x = 0;//用在cmp,动态排序

bool cmp(Student A, Student B)
{
    return A.grade[x] > B.grade[x];
}

int main()
{
    int N = 0, M = 0;
    char Symbol[5] = "ACME";
    scanf("%d %d", &N, &M);
    for(int i = 0; i<N; i++)
    {
        scanf("%d %d %d %d", &S[i].ID, &S[i].grade[1], &S[i].grade[2], &S[i].grade[3]);
        S[i].grade[0] = (int)( (double)( S[i].grade[1] + S[i].grade[2] + S[i].grade[3]) / 3.0 + 0.5 );//平均
        S[i].best_rank = 9999;//先设置为无穷大
    }
    for(x = 0; x<4; x++)
    {
        sort(S, S+N, cmp);//排序后计算本次排名,然后比较是否为最小
        S[0].temp_rank = 1;
        for(int i = 1; i<N; i++)
        {
            if(S[i].grade[x] != S[i-1].grade[x]) S[i].temp_rank = i+1;
            else S[i].temp_rank = S[i-1].temp_rank;
        }
        for(int i = 0; i<N; i++)
        {
            if(S[i].temp_rank < S[i].best_rank)
            {
                S[i].best_rank = S[i].temp_rank;
                S[i].symbol = x;
            }
        }
    }
    for(int i = 0; i<M; i++)
    {
        int ID = 0;
        scanf("%d", &ID);
        int flag = 0;
        for(int j = 0; j<N; j++)//扫描输出;讲道理时间会增加,但和上一个方法是相同的时间复杂度
        {
            if(S[j].ID == ID)
            {
                printf("%d %c\n", S[j].best_rank, Symbol[S[j].symbol]);
                flag = 1;
                break;
            }
        }
        if(!flag) printf("N/A\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86376380