PTA 1012 The Best Rank (25 分)

1012 The Best Rank (25 分)
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.
Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A




解析

排序题。一开始我还是是节省时间。后来才发现是模拟题。为什么呢:因为这道题的编程很复杂,但是给出的测试点的数据其实很少。
在写着道题的时候,我才明白了数据库的重要性。要好好学DB。



这题是完全是看柳神的做法做的。
其中的flag震惊我了,居然还有这种用法



#include<vector>
#include<string>
#include<iostream>
#include<map>
#include<algorithm>
using namespace std;
struct student{
	int id,best;
	int score[4];
	int rating[4];
};
int exist[10000000] = {0};
int flag;
const char AC[4] = { 'A','C','M','E' };
bool cmp(student a, student b) {
	return a.score[flag] > b.score[flag];
}
int main()
{
	int n, m;
	cin >> n >> m;
	vector<student> data(n);
	for (int i = 0; i < n; i++) {
		cin >> data[i].id >> data[i].score[1] >> data[i].score[2] >> data[i].score[3];
		data[i].score[0] = (int)((0.0 + data[i].score[1] + data[i].score[2] + data[i].score[3]) / 3+0.5);
	}
	for (flag = 0; flag < 4; flag++) {
		sort(data.begin(), data.end(), cmp);
		data[0].rating[flag] = 1;
		for (int i = 1; i < n; i++)
			data[i].rating[flag] = (data[i - 1].score[flag] == data[i].score[flag]) ? data[i - 1].rating[flag] : i+1;
	}
	for (int i = 0; i < n; i++) {
		exist[data[i].id] = i+1;
		data[i].best = min_element(begin(data[i].rating),end(data[i].rating))-begin(data[i].rating);
	}
	int find_id;
	for (int i = 0; i < m; i++) {
		cin >> find_id;
		auto it = exist[find_id];
		if (it) {
			it--;
			cout << data[it].rating[data[it].best] << " " << AC[data[it].best]<<endl;
		}
		else
			cout << "N/A"<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/82861814