PAT(甲级)1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

简要大义:输入两个数分别表示学生数和查询数,然后每一行输入每一个学生的学号和三门课程CME的成绩,再算出每个人的平均分,对每一科都进行排序包括平均分。然后每一行输入一个学生的学号,如果学生存在,就输出他排名最高的名词以及那门课的标号,如果存在同名次的学科,就按ACME的优先级输出,如果学生不存在就输出N/A;

一开始想用map做,但是不会对map每一行的第一个进行排序,参考了柳神的代码,采用结构体,每个结构体保存了所有相关的数据,包括每门成绩,名次,这样比较起来也比较方便。

ps:在排名的时候,同名次的话名次就相等,但是不影响后面的名次。

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct node{
    int id, best;
    char kemu;
    int score[4], rank[4];
}stud[2005];
int exist[1000000];      //排序时候结构体的位置会发生变化,所以用数组便于判断结构体的位置
string str1 = "ACME";
int flag = -1;
bool cmp(node a,node b)  //用flag可以对相应位置的成绩进行排名
{
    return a.score[flag]>b.score[flag];
};
int main()
{
    int N,M;
    cin >> N >> M;
    for (int i = 0; i < N;i++)   //对基础成绩的输入
    {
        cin >> stud[i].id;
        cin >> stud[i].score[1] >> stud[i].score[2] >> stud[i].score[3];
        stud[i].score[0] = (stud[i].score[1] + stud[i].score[2] + stud[i].score[3])/3;
    }
    for (flag = 0; flag < 4;flag++)  //生成名次
    {
        sort(stud, stud + N, cmp);
        stud[0].rank[flag] = 1;
        for (int i = 1; i < N;i++)
        {
            stud[i].rank[flag] = i + 1;
            if(stud[i].score[flag] == stud[i-1].score[flag])
                stud[i].rank[flag] = stud[i-1].rank[flag];
        }
    }
    for (int i = 0; i < N;i++)  //根据名次选出名次最高的排名以及对应的课程
    {
        exist[stud[i].id] = i+1;
        int min = stud[i].rank[0];
        stud[i].kemu = str1[0];
        for (int j = 1; j < 4;j++)
        {
            if(min>stud[i].rank[j])
            {
                 min = stud[i].rank[j];
                 stud[i].kemu = str1[j];
            }
        }
        stud[i].best = min;
    }
    for (int t = 0; t < M;t++)  //输出结果
    {
        int id1;
        cin >> id1;
        int q = exist[id1];
        if(q == NULL)
        {
            cout << "N/A" << '\n';
            continue;
        }
        cout << stud[q-1].best << ' ' << stud[q-1].kemu << '\n';
    }
        return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35601980/article/details/88913685