模拟_1012 The Best Rank (25 分)

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

只需要将每种排序的名次存放在一个数组中,然后根据优先级,找出名次最靠前的名次即可

题目中需要注意的地方为:如果分数相同,则名次也也要相同

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <cmath>
#define INF 0x3f3f3f3f

using namespace std;
typedef long long ll;
const int maxn = 2010;
const int maxm = 1e7+10;
int n,m,pos;
struct student{
    int num;
    int grade[5];
}stu[maxn];
int Rank[maxm][5];
char sub[5] = {' ','A','C','M','E'};

bool cmp(const student &a,const student &b)
{
    return a.grade[pos] > b.grade[pos];
}
int main()
{
    scanf("%d%d",&n,&m);
    int num;
    for(int i = 1;i <= n;i ++)
    {
        scanf("%d%d%d%d",&stu[i].num,&stu[i].grade[2],&stu[i].grade[3],&stu[i].grade[4]);
        stu[i].grade[1] = stu[i].grade[2] + stu[i].grade[3] + stu[i].grade[4];
    }
    for(pos = 1;pos <= 4;pos ++)
    {
        sort(stu+1,stu+1+n,cmp);
        for(int j = 1;j <= n;j ++)
            if(stu[j].grade[pos] == stu[j-1].grade[pos])
                Rank[stu[j].num][pos] = Rank[stu[j-1].num][pos];
            else
                Rank[stu[j].num][pos] = j;
//        for(int j = 1;j <= n;j++)
//            cout << stu[j].num<<endl;
//        cout <<"*************************"<<endl;
    }
    for(int i = 1;i <= m;i ++)
    {
        scanf("%d",&num);
        if(Rank[num][1] == 0)
            printf("N/A\n");
        else
        {
            int min_pos = n+1,ans = 0;
            for(int j = 1;j <= 4;j ++)
                if(Rank[num][j] < min_pos)
                    ans = j,min_pos = Rank[num][j];
            printf("%d %c\n",min_pos,sub[ans]);
        }
    }
    return 0;
}

 参考博客

https://blog.csdn.net/weixin_42671353/article/category/7910722

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/84476424
今日推荐