1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
#include<iostream>
#include<map>
#include<algorithm>
using namespace std;
#define MAX 0x7fffffff
struct grade
{
    int id;
    int c;
    int m;
    int e;
    int a;
    int best_rank;
    char subject;
    int order;
};
bool cmp_c(grade a, grade b){

    return a.c > b.c;
}

bool cmp_m(grade a, grade b){

    return a.m > b.m;
}

bool cmp_e(grade a, grade b){

    return a.e > b.e;
}

bool cmp_a(grade a, grade b){

    return a.a > b.a;
}

bool cmp_order(grade a, grade b){

    return a.order < b.order;
}

int main(){

    grade stu_grade[2001];
    map<int, int> stu_map;
    int n, m;
    cin >> n >> m;
    for(int i = 0; i < n; i++){

        cin >> stu_grade[i].id >> stu_grade[i].c >> stu_grade[i].m >> stu_grade[i].e;
        stu_grade[i].a = (stu_grade[i].c + stu_grade[i].m + stu_grade[i].e) / 3;
        stu_map[stu_grade[i].id] = i;
        stu_grade[i].best_rank = MAX;
        stu_grade[i].order = i;
    }

    int b[2001];
    for(int i = 0; i < m; i++){

        cin >> b[i];

    }

    //a
    sort(stu_grade, stu_grade + n, cmp_a);
    int temp = stu_grade[0].a;
    int rank = 1;
    for(int i = 0; i < n; i++){
        
        if (stu_grade[i].a == temp)
        {

            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'A';
            }
                

        }else
        {

            rank = i + 1;
            temp = stu_grade[i].a;
            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'A';
            }
            
        }
        
        

    }
    
    //c
    sort(stu_grade, stu_grade + n, cmp_c);
    temp = stu_grade[0].c;
    rank = 1;
    for(int i = 0; i < n; i++){
        
        if (stu_grade[i].c == temp)
        {

            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'C';
            }
                

        }else
        {

            rank = i + 1;
            temp = stu_grade[i].c;
            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'C';
            }
            
        }
        
        

    }

    //m

    sort(stu_grade, stu_grade + n, cmp_m);
    temp = stu_grade[0].m;
    rank = 1;
    for(int i = 0; i < n; i++){
        
        if (stu_grade[i].m == temp)
        {

            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'M';
            }
                

        }else
        {

            rank = i + 1;
            temp = stu_grade[i].m;
            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'M';
            }
            
        }
        
        

    }

    //e

    sort(stu_grade, stu_grade + n, cmp_e);
    temp = stu_grade[0].e;
    rank = 1;
    for(int i = 0; i < n; i++){
        
        if (stu_grade[i].e == temp)
        {

            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'E';
            }
                

        }else
        {

            rank = i + 1;
            temp = stu_grade[i].e;
            if(stu_grade[i].best_rank > rank){
                stu_grade[i].best_rank = rank;
                stu_grade[i].subject = 'E';
            }
            
        }
        
        

    }
    sort(stu_grade, stu_grade + n, cmp_order);
    // for(int i = 0 ; i < n; i++){

    //    cout << stu_grade[i].id << " " << stu_grade[i].c << " " << stu_grade[i].m << " " << stu_grade[i].e << " " << stu_grade[i].a  << " " << stu_grade[i].order<< endl;

    // }

    
    for(int i = 0; i < m; i++){

        if(stu_map.find(b[i]) == stu_map.end()){

            cout << "N/A" << endl;

        }else
        {

            cout << stu_grade[stu_map[b[i]]].best_rank << " " << stu_grade[stu_map[b[i]]].subject << endl;

        }


        
    }

    // for(int i = 0 ; i < n; i++){

    //    cout << stu_grade[i].id << " " << stu_grade[i].c << " " << stu_grade[i].m << " " << stu_grade[i].e << " " << stu_grade[i].a << endl;

    // }
    
    return 0;
}
发布了32 篇原创文章 · 获赞 0 · 访问量 450

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/103940183
今日推荐