PAT A1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题意:

首先输入学生的id、编程分C、数学分M、英语分E,求出平均分A;再输入学生id查询其排名最高的科目,如果不存在输出N/A,否侧输出科目的排名和科目名.

思路:

(1)对每门科目先排序再排名,每门科目的排名存放在二维数组Rank[学生id][科目号]中;
(2)依据给定的学生id,比较其各科目的分数,输出排名最高的科目,相同排名按照A>C>M>E的优先级输出.

代码:

//先排序再排名
#include<cstdio>
#include<algorithm>
using namespace std;

struct student{
	int id,grade[4];
}stu[2010];
char course[4]={'A','C','M','E'};
int Rank[10000000][4] = {0};//如果放在main里面,该数组过大无法初始化 
int k;
bool cmp(student a,student b){
	return a.grade[k]>b.grade[k];
}

int main(){
	int N,M;
	scanf("%d %d",&N,&M);
	for(int i=0;i<N;i++){
		scanf("%d %d %d %d",&stu[i].id,&stu[i].grade[1],&stu[i].grade[2],&stu[i].grade[3]);
		stu[i].grade[0] = (stu[i].grade[1]+stu[i].grade[2]+stu[i].grade[3])/3; 
	}
	for(k = 0;k<4;k++){
		sort(stu,stu+N,cmp);//排序
		Rank[stu[0].id][k] = 1;//排名
		for(int i=1;i<N;i++){
			if(stu[i].grade[k]==stu[i-1].grade[k]){
				Rank[stu[i].id][k] =  Rank[stu[i-1].id][k];
			}else{
				Rank[stu[i].id][k] = i+1;
			}
		}
	}
	for(int i=0;i<M;i++){
		int id;
		scanf("%d",&id);
		if(Rank[id][0]==0){
			printf("N/A\n");
		}else{
			int min = 0; 
			for(int j=0;j<4;j++){
				if(Rank[id][j]<Rank[id][min]){
					min = j;
				}
			}
			printf("%d %c\n",Rank[id][min],course[min]);
		}
	}
	return 0;
} 
发布了26 篇原创文章 · 获赞 0 · 访问量 471

猜你喜欢

转载自blog.csdn.net/PanYiAn9/article/details/104078267