HDU-2119 Matrix

Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.

Input

There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

Output

For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

Sample Input

3 3 
0 0 0
1 0 1
0 1 0
0

Sample Output

2

题意:

给你一个N*M的0,1矩阵,你每次可以选特定的某行或某列,然后删除该行/列的所有1,问你最少需要几次操作能删除矩阵的所有1.

解题思路:

假设每次去掉一行或者一列,那么两次去除之后在矩阵中肯定会有一个相交的点,这样理解的话,问题就转化为求出最少的相交点,也就是说以二维数组行的下标为一个结合,列的下标为另外一个集合,运用匈牙利算法来求解就可以了。

 本题的问题就是求该二分图的最小边覆盖点集.使得每条边都被至少1个点覆盖.(想想是不是) 最小覆盖集大小==最大匹配数.

代码:

#include <stdio.h>
#include <string.h>
int e[110][110];
int match[110],book[110];
int m;

int dfs(int u)
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(book[i]==0&&e[u][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int i,j,n,a,ans;
	while(scanf("%d",&n),n!=0)
	{
		scanf("%d",&m);
		memset(e,-1,sizeof(e));
		memset(book,0,sizeof(book));
		memset(match,0,sizeof(match));
		for(i=1;i<=n;i++)
		{	
			for(j=1;j<=m;j++)
			{
				scanf("%d",&e[i][j]);
			}
		}
		ans=0;	
		for(i=1;i<=n;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81543283