HDU 1082 Matrix Chain Multiplication

Matrix Chain Multiplication

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2098 Accepted Submission(s): 1343

Problem Description

Matrix multiplication problem is a typical example of dynamical programming.
Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)C and A(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.
Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line }
Line = Expression
Expression = Matrix | “(” Expression Expression “)”
Matrix = “A” | “B” | “C” | … | “X” | “Y” | “Z”

Output

For each expression found in the second part of the input file, print one line containing the word “error” if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

Source

University of Ulm Local Contest 1996

Recommend

We have carefully selected several similar problems for you: 1074 1081 1080 1505 1098

题意

给出n个矩阵,求按照字符串的计算方式,初等乘法使用的总次数。

解题思路

利用栈模拟,注意(A)这种情况。贡献三次RE。

代码

#include<bits/stdc++.h>
using namespace std;
#define maxn 30

struct node
{
    int r,c;
    node() {}
    node(int a,int b)
    {
        r=a;
        c=b;
    }
} arr[maxn];
stack<node> s;

int main()
{
//    freopen("in.txt","r",stdin);
    int x,y,n;
    scanf("%d",&n);
    getchar();
    char t;
    for(int i=0; i<n; i++)
    {
        scanf("%c%d%d",&t,&x,&y);
        arr[t-'A'].r=x;
        arr[t-'A'].c=y;
        getchar();
    }
    string str;
    while(cin>>str)
    {
        while(!s.empty()) s.pop();
        int len=str.length();
        int flag=1,sum=0;
        for(int i=0; i<len; i++)
        {
            if (str[i]=='(') continue;
            if(str[i]==')')
            {
                if(s.size()==1) break;
                node a=s.top();
                s.pop();
                node b=s.top();
                s.pop();
                if(b.c!=a.r)
                {
                    flag=0;
                    continue;
                }
                else
                {
                    sum+=b.r*b.c*a.c;
                    s.push(node(b.r,a.c));
                }
            }
            else  s.push(arr[str[i]-'A']);
        }
        if(flag) printf("%d\n",sum);
        else puts("error");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_36258516/article/details/79647052