hdu2119:Matrix

http://acm.hdu.edu.cn/showproblem.php?pid=2119

Problem Description

Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.

Input

There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

Output

For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

Sample Input

3 3

0 0 0

1 0 1

0 1 0

0

Sample Output

2

匈牙利算法,代码:

#include<stdio.h>
#include<string.h>
#define N 550
int a[N],line[N][N],book[N];
int k,m,n;
int find(int x)
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(line[x][i]==1&&book[i]==0)
		{
			book[i]=1;
			if(a[i]==0||find(a[i]))
			{
				a[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int sum,i,j;
	while(scanf("%d",&n),n!=0)
	{
		sum=0;
		scanf("%d",&m);
		memset(a,0,sizeof(a));
		memset(line,0,sizeof(line));
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%d",&line[i][j]);
		for(i=1;i<=n;i++)
		{
			memset(book,0,sizeof(book));
			if(find(i))
				sum++;
		}	
		printf("%d\n",sum);	
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41505957/article/details/81699532
今日推荐