hdu 简单DP 1012 Matrix Swapping II

Matrix Swapping II

Time Limit : 9000/3000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 17

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

Input

There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

Output

Output one line for each test case, indicating the maximum possible goodness.

Sample Input

3 4
1011
1001
0001
3 4
1010
1001
0001

Sample Output

4
2

Note: Huge Input, scanf() is recommended.

Source

2009 Multi-University Training Contest 2 - Host by TJU

//for(int j=n-1;j>=1;j--)  dp[j]+=dp[j+1];
/*
     1011
     1111
     1101
     1101
     如果没有这句话答案是8,有了这句正确的是9,就是有可能下半部分要,不要上半部分的1会更大
*/
#include <bits/stdc++.h>
using namespace std;
char a;
int dp[1005],h[1005][1005],n,m; //h[i][j]代表包括到第i行第j列,前面有几个连续的1
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        getchar(); //很重要,不能少
        memset(h,0,sizeof(h));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%c",&a);
                if(a=='1') h[i][j]=h[i-1][j]+1; //如果为1,就是上一行的数+1
                else h[i][j]=0;   //否则清0
            }
            getchar(); //接受换行符,否则读入就会出错
        }
        int ans=-1;
        for(int i=1;i<=n;i++)
        { 
            memset(dp,0,sizeof(dp));
            for(int j=1;j<=m;j++)   //每一行中1、2、3……有几个
                dp[h[i][j]]++;
            for(int j=n-1;j>=1;j--)  //!!!!!!少了就wa
                dp[j]+=dp[j+1];
            for(int j=1;j<=n;j++)    //更新答案
                ans=max(ans,dp[j]*j);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81007028