1392:繁忙的都市(city)

【题目描述】

城市C是一个非常繁忙的大都市,城市中的道路十分的拥挤,于是市长决定对其中的道路进行改造。城市C的道路是这样分布的:城市中有n个交叉路口,有些交叉路口之间有道路相连,两个交叉路口之间最多有一条道路相连接。这些道路是双向的,且把所有的交叉路口直接或间接的连接起来了。每条道路都有一个分值,分值越小表示这个道路越繁忙,越需要进行改造。但是市政府的资金有限,市长希望进行改造的道路越少越好,于是他提出下面的要求:

1.改造的那些道路能够把所有的交叉路口直接或间接的连通起来。

2.在满足要求1的情况下,改造的道路尽量少。

3.在满足要求1、2的情况下,改造的那些道路中分值最大值尽量小。

作为市规划局的你,应当作出最佳的决策,选择那些道路应当被修建。

【输入】

第一行有两个整数n,m表示城市有n个交叉路口,m条道路。接下来m行是对每条道路的描述,u, v, c表示交叉路口u和v之间有道路相连,分值为c。(1≤n≤300,1≤c≤10000)。

【输出】

两个整数s, max,表示你选出了几条道路,分值最大的那条道路的分值是多少。

【输入样例】

4 5
1 2 3
1 4 5
2 4 7
2 3 6
3 4 8

【输出样例】

3 6

像这种涉及坐标的还是Kruskal算法比较好

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int from,to;
    int dis;
    friend bool operator <(node A,node B)
    {
        return A.dis<B.dis;
    }
}mapp[20000],s[20000];
int n,m;
int p[1000];
int findth(int x)
{
    if(x==p[x]) return x;
    return p[x]=findth(p[x]);
}

void unionn(int x,int y)
{
    int xx=findth(x);
    int yy=findth(y);
    if(xx!=yy) p[yy]=xx;
}
int cnt=0;
void Kruskal()
{
    sort(mapp+1,mapp+1+m);
    for(int i=1;i<=m;i++){
        if(findth(mapp[i].from)==findth(mapp[i].to)) continue;
        unionn(mapp[i].from,mapp[i].to);
        cnt++;
        s[cnt].from=mapp[i].from;
        s[cnt].to=mapp[i].to;
        s[cnt].dis=mapp[i].dis;

    }
}
int main()
{
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++) p[i]=i;
    for(int i=1;i<=m;i++){
        int x,y,z;
        scanf("%d %d %d",&mapp[i].from,&mapp[i].to,&mapp[i].dis);
    }
    Kruskal();
    sort(s+1,s+1+cnt);
    printf("%d %d\n",cnt,s[cnt].dis);

    return 0;
}
扫描二维码关注公众号,回复: 2619800 查看本文章

猜你喜欢

转载自blog.csdn.net/Wchenchen0/article/details/81486320