HDOJ-1969 Pie

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9369    Accepted Submission(s): 3396


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
   
   
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
   
   
25.1327 3.1416 50.2655
介个题用二分算法,将每个人得到的蛋糕二分就行啦,但是要注意判断函数的编写。
代码在下边:
#include <cstdio>
#include <cmath>
#include <iostream>
#define PI acos(-1.0)
using namespace std;
double sum,a[10000+10];
int n,f,r;
const double eps=1e-6;
bool cmp(double x){
	int cnt=0;
	for(int i=0;i<n;i++){
		cnt+=int(a[i]/x);
	}
	return cnt>=f;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%d%d",&n,&f);
		f++;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&r);
			a[i]=PI*r*r;
			sum+=a[i];
		}
		double l=0,r=sum/f;
		while(r-l>eps)
		{
			double mid=(l+r)/2.0;
			if(cmp(mid)) l=mid;
			else r=mid;
		}
		printf("%.4lf\n",l);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Poseidon__ming/article/details/52046628
pie