I - Big Event in HDU HDU - 1171(母函数、背包两种解法)

I - Big Event in HDU HDU - 1171 

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

(1)母函数解法:

#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=50+5;
const int mmax=250000+7;
const int MOD = 1e5+ 7;
int val[N];
int a[mmax],t[mmax],num[N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n<=0)
            break;
        int maxl=0;
        for(int i=0; i<n; i++)
        {
            cin>>val[i]>>num[i];
            maxl+=val[i]*num[i];
        }
        int mid=maxl/2;
        memset(a,0,sizeof(int)*mid+8);
        memset(t,0,sizeof(int)*mid+8);
        a[0]=1;              //初始条件,价值为0的情况是存在的。
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<=mid; j++)  //计算记录总价值在一半之内的情况即可
            {
                if(a[j])
                {
                    for(int k=0; j+k*val[i]<=mid&&k<=num[i]; k++)
                    {
                        t[j+k*val[i]]=1;// t[j+k*val[i]]+=a[j];
                    }
                }
            }
            for(int j=0; j<=mid; j++)
            {
                a[j]=t[j];
                t[j]=0;
            }
        }
        for(int i=mid; i>=0; i--)   //mid存在未0的情况
        {
            if(a[i])
            {
                printf("%d %d\n",maxl-i,i);
                break;
            }
        }
    }
    return 0;
}

(2)背包解法:

#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=50+5;
const int mmax=250000+7;
const int MOD = 1e5+ 7;
int val[N];
int dp[mmax],num[N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n<=0)
            break;
        int maxl=0;
        for(int i=0; i<n; i++)
        {
            cin>>val[i]>>num[i];
            maxl+=val[i]*num[i];
        }
        memset(dp,0,sizeof(dp));   //初始化
        int mid=maxl/2;
       for(int i=0;i<n;i++){
        for(int j=1;j<=num[i];j++){
            for(int k=mid;k>=val[i];k--)
                dp[k]=max(dp[k],dp[k-val[i]]+val[i]);  //更新总价值为K时的情况
        }
       }
       printf("%d %d\n",maxl-dp[mid],dp[mid]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/clz16251102113/article/details/81209108
今日推荐