HDU - 1171 Big Event in HDU

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
20 10
40 40
问题链接http://acm.hdu.edu.cn/showproblem.php?pid=1171
问题简述:输入一个数n代表设备种类数,以下有n行代表每种设备,每行第一个数为设备的价值,第二个数为设备的数量。要求把所有设备分为两份,令两份的设备总价值最接近并且第一份大于第二份。
问题分析:把所有设备的价值加起来除与2可以得到一个中间值,此题就变成了01背包。算出不大于这个中间值的最大值即可。(这个01背包没有背包空间,先把每种设备的每一个都单独拿出来作为一个设备放在数组里,进行单向DP)(可得状态方程:dp[j]=max(dp[j],dp[j-val[i]]+val[i]);)
AC通过的C++语言程序如下:

#include<iostream>
#include<cstring>
using namespace std;
int val[1000000] = { 0 };
int dp[1000000] = { 0 };
int c = 0, sum = 0;
void dps(int zx)
{
	for (int i = 0; i < c; i++)
	{
		for (int j = zx; j >= val[i]; j--)
		{
			if (dp[j] > dp[j - val[i]] + val[i])
			{
				dp[j] = dp[j];
			}
			else
			{
				dp[j] = dp[j - val[i]] + val[i];
			}
		}
	}
}
int main()
{
	int n;
	while (cin >> n)
	{
		if (n > 0)
		{
			for (int i = 0; i < n; i++)
			{
				int a, b;
				cin >> a >> b;
				for (int j = 0; j < b; j++)
				{
					val[c] = a;
					c++;
				}
				sum = sum + a * b;
			}
			int zxc = sum / 2;
			dps(zxc);
			if (dp[zxc] > sum - dp[zxc]) { cout << dp[zxc] << " " << sum - dp[zxc] << endl; }
			else { cout << sum - dp[zxc] << " " << dp[zxc] << endl; }
			memset(dp, 0, sizeof(dp));
			memset(val, 0, sizeof(val));
			c = 0; sum = 0;
		}
		else break;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44012745/article/details/86618738