Big Event in HDU (dp)

     Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
    The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
    A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input

    2
    10 1
    20 1
    3
    10 1
    20 2
    30 1
    -1

Sample Output

    20 10
    40 40

题意:有N种物品,每种物品都对应一个M值,表示该物品有M件。要将这些物品能较好得平分给两个社团,即两个社团所得的价值总量差要使得最小,Computer College 所获得的价值应不小于Software College 所获得的价值

分析:可以转换成一个01背包问题,先求出所有物品合起来的价值最大值sum,那么对于Software College 来说就转换成了它有一个sum/2的容量的背包,求它能装的物品的价值的最大值。

#include <stdio.h>
#include <string.h>
#define max(a,b) (a>b?a:b)

int main()
{
    int i,j,k,a,b,n,sum;
    int v[5010],dp[250010];
    while(scanf("%d",&n), n > 0)
    {
        memset(dp,0,sizeof(dp));
        k = 0;
        sum = 0;
        for(i = 0;i < n; i ++)
        {
            scanf("%d%d",&a,&b);
            while(b --)
            {
                v[k++] = a;
                sum += a;
            }
        }
        for(i = 0;i < k;i ++)
        {
            for(j = sum/2; j >= v[i]; j --)
                dp[j] = max(dp[j],dp[j-v[i]]+v[i]);
        }
        printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81332952
今日推荐