杭电 1232(并查集练习)

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67520    Accepted Submission(s): 36018


 

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 

 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 

 

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。 

 

Sample Input

 

4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0

 

Sample Output

 

1 0 2 998

Hint

Hint Huge input, scanf is recommended.

 

Source

浙大计算机研究生复试上机考试-2005年

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1233 1272 1875 1879 1213 

 

思路:还是套并查集的模板找老大,最后算出有几个老大 ,然后减1;

#include <bits/stdc++.h>
#define maxn 200005
typedef long long ll;
using namespace std;
ll a[maxn];
set<ll>b;
ll find(ll x)
{
    return a[x] == x ? x : a[x] = find(a[x]);
}
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0),cout.tie(0);
    ll n,m,x,y;
    while(cin >> n >> m && n)
    {
        memset(a,0,sizeof(a));
        b.clear();
        for(int i = 1; i <= n; i ++)
        {
            a[i] = i;
        }
        for(int i =0; i < m; i ++)
        {
            cin >> x >> y;
            a[find(y)] = find(x);
        }
        for(int i = 1; i <= n; i ++)
        {
            b.insert(find(i));
        }
        cout << b.size() - 1 << endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/zzzanj/article/details/81252453