ACM练习 杭电oj 1880 魔咒词典

http://acm.hdu.edu.cn/showproblem.php?pid=1880

魔咒词典

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17132    Accepted Submission(s): 4054

Problem Description

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output

light the wand
accio
what?
what?

思路:搜map训练题的时候发现的,某个sha博主用map做的,然后第一次用了map来存放,一直超内存,后来发现根本不能用map,换成两个string数组,过了。输入的时候注意一下,感觉c和c++结合反正有点怪并且不高逼格,将就一下。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string> 
#include<map> 
using namespace std;
string ma[100005],mb[100005];
int main()
{
	char in[101];
	int n;
	int k = 0;
	while (~scanf("%[^\n]s",in))
	{
		getchar();
		if (strcmp(in, "@END@") == 0)
		{
			break;
		}
		int flag = 1;
		for (int i = 0; i < strlen(in); i++)
		{
			if (in[i] != ']'&&flag)
			{
				ma[k] += in[i];
			}
			else if(in[i] == ']')
			{
				ma[k] += in[i];
				flag = 0;
				continue;
			} 
			else if(in[i-1]==']')
			{
				continue;
			}
			else
			{
				mb[k] += in[i];
			}
		}
		k++;
	}
	scanf("%d", &n);
	getchar();
	char tt[101];
	for (int i = 0; i < n; i++)
	{
		scanf("%[^\n]s", tt);
		getchar();
		if (tt[0] != '[')
		{
			int flag = 0;
			for (int j = 0; j< k; j++)
			{
				if (mb[j] == tt)
				{
					int len = ma[j].length();
					printf("%s\n", ma[j].substr(1, len - 2).c_str());
					flag = 1;
					break;
				}
			}
			if (!flag)
			{
				printf("what?\n");
			}
		}
		else
		{
			int flag = 0;
			for (int j = 0; j< k; j++)
			{
				if (ma[j] == tt)
				{
					printf("%s\n", mb[j].c_str());
					flag = 1;
					break;
				}
			}
			if (!flag)
			{
				printf("what?\n");
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/BIEBIBIBI/article/details/83549155