The Triangle(dp基础题)

The Triangle


题目描述:

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入描述:

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出描述:

Your program is to write to standard output. The highest sum is written as an integer.

样例输入:

复制
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

样例输出:

30


思路:

d[i][j]=max(d[i+1][j],d[i+1][j+1])+map[i][j];(核心)

           d[i][j]

d[i+1][j]    d[i+1][j+1]

如上d[i][j]的值就是,将它下面两个数中,大的那一个,再加上本身这一点的值map[i][j]

从第n行把状态一直更新到第一行,那d[1][1]就是我们所要求的值。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[105][105],d[105][105];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(map,0,sizeof(map));
        memset(d,0,sizeof(d));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=i;j++)
              scanf("%d",&map[i][j]);
        for(int i=n;i>0;i--)
            for(int j=1;j<=i;j++)
                d[i][j]=max(d[i+1][j],d[i+1][j+1])+map[i][j];
        printf("%d\n",d[1][1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/80347362
今日推荐