The Triangle

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

AC代码:

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int a[105][105],dp[105][105];
int main() {
	int n,maxt=0;
	int sum=-1;
	scanf("%d",&n);
	for(int i=1; i<=n; i++) {
		for(int j=1; j<=i; j++)
			scanf("%d",&a[i][j]);
	}
	memset(dp,0,sizeof(dp));
	dp[1][1]=a[1][1];//初始化dp数组
	for(int i=2; i<=n; i++) {
		for(int j=1; j<=i; j++) {//遍历每一层的每一个数字
			if((i-1)>=1) {
				if(j-1>=1)
					dp[i][j]=max(dp[i][j],dp[i-1][j-1]+a[i][j]);
                    /*j-1>=1说明此时dp[i][j]能由dp[i-1][j-1]+a[i][j],dp[i][j]
                     或者由dp[i][j],dp[i-1][j]+a[i][j]更新*/
					dp[i][j]=max(dp[i][j],dp[i-1][j]+a[i][j]);
                   /*若j-1<1,说明j是第一列,不能由上一行的
                     j-1列得到,只能由dp[i][j],dp[i-1][j]+a[i][j]更新*/
			}
		}
	}
	for(int i=1;i<=n;i++)
	sum=max(sum,dp[n][i]);
	printf("%d\n",sum);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41938789/article/details/84860159