HDU 2955 DP

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28826    Accepted Submission(s): 10584


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
 
  
30.04 31 0.022 0.033 0.050.06 32 0.032 0.033 0.050.10 31 0.032 0.023 0.05
 

Sample Output
 
  
246

废话不多说直接上代码:

#include<iostream>
#include<cstdio>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<map>
#include<queue>
#include<stack>
using namespace std;
/*
用金钱作为背包,把被抓到的概率做价值,每次更新就好
*/
int main(){
    int t,n,i,j,m[110];
    float P,p[110],dp[10010];//dp[]数组下标为此时抢到的钱,值为被抓的概率
    cin>>t;
    while(t--){
        memset(dp,0,sizeof(dp));
        int sum=0;
        cin>>P>>n;
        P=1-P;
        for(i=1;i<=n;i++){
            cin>>m[i]>>p[i];
            p[i]=1.0-p[i];
            sum+=m[i];
        }
        dp[0]=1;
        for( i=1;i<=n;i++){
            for(j=sum;j>=m[i];j--){
                dp[j]=max(dp[j],dp[j-m[i]]*p[i]);
                /*
                因为每次被抓到的这一事件的相互独立的,所以要用乘法
                第一次只有dp[0]有值
                第二次只有dp[0],dp[m[1]],有值
                第三次只有dp[0],dp[m[1]],dp[m[2]],dp[m[1]+m[2]],有值
                ...
                其他的均为0
                */
            }
        }
        for(j=sum;j>=0;j--){
            if(dp[j]>=P) break;
        }
        cout<<j<<endl;;
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41199327/article/details/79947858